cts projects and software logo

Systemanforderungen

Systemvoraussetzungen

Folgende Komponenten werden benötigt, um ClassAd zu nutzen:

  • PHP 4/5 mit aktivierter und funktionierender Sessionverwaltung, aktivierter Uploadmöglichkeit;
  • MySQL Datenbank (für die Datenbankwartung wird mind. MySQL V3.23 benötigt)
  • aktivierte Cookies
  • GD-Library installiert (wird zur Grafikkonvertierung genutzt) / GD-Version 2.0 ist dringend auf Windows-Systemen empfohlen, da nur hier die Ausgabe als 24-Bit Grafik unterstützt wird
  • einige Minuten zur Installation

ClassAd wurde getestet und entwickelt mit PHP Version 5.0.3.

Einsatz unter PHP 5.x

ClassAd ab der Version ab 3.5 wurden so verändert, dass eine Ausführung mit PHP5 möglich und gewünscht ist. Insbesondere wurde hierbei die Direktive 'REGISTER_GLOBALS' in der php.ini beachtet, so dass ClassAd nun auch eingesetzt werden kann, wenn die PHP5 Standardeinstellung ('off') auf dem Webserver konfiguriert ist.

ClassAd 5 und X-Versionen, werden ausschließlich PHP5/6 unterstützen, d.h. nicht mehr unter PHP4 lauffähig sein.

Einsatz unter PHP 4.x

Beim Erstellung von ClassAd wurde auf weitgehende Kompatilibität zu PHP4 geachtet, d.h. alle ClassAd-Versionen bis 4.5 sollten problemlos unter PHP4 lauffähig sein.

Da wir es als notwendig ansehen, den Schnitt

ClassAd 5 und X-Versionen, werden ausschließlich PHP5/6 unterstützen, d.h. nicht mehr unter PHP4 lauffähig sein.

Impressum | Datenschutz-Erklärung | AGB | Kontaktformular | ©2008 cts projects&software